Skip to content

Slow File Copy from Vista to Windows Server 2003

February 25, 2008

Last night I tried copying 37GB of files from my Vista Ultimate PC to my server running Windows Small Business Server 2003. Even though I was using Robocopy, and had installed the Vista hotfixes meant to help address slow file operations (see, e.g., Knowledge Base articles KB931770 and KB938979), the process was proceeding abysmally slowly (about 1GB per hour).

So I did a Google search and came up with a few new ideas to try: turning off Remote Differential Compression and Receive Window Auto Tuning; and  trying various other Microsoft suggested workarounds. I had just recently updated network drivers and even restarted Small Business Server 2003, but none of these did any good.

I do not appear to be alone, but neither do my symptoms appear widespread. These large file transfers are infrequent enough and difficult enough to diagnose, that I’ll put off further research until after Vista SP1 is available and installed.

Advertisements

From → Uncategorized

Leave a Comment

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: