Skip to content

Problems with Windows 7 and Domains

January 31, 2009

I recently encountered problems with Windows 7 logging on to our home domain controlled by our Small Business Server 2003 machine. Joining the domain was no problem and Windows 7 worked well for several days until it started to get stuck on the Welcome screen after logging in.

I discovered that somehow the PC on which I had installed Windows 7 had become disassociated with our domain, because after restarting and booting into Vista, I got an error stating that “the trust relationship between this workstation and the primary domain failed” quitting and then rejoining the domain solved the problem in Vista, but not in Windows 7. In Windows 7, I could log on locally with a user account not associated with the domain, leave the domain and then ostensibly rejoin the domain, but when I try to reboot after rejoining I got the same hang on the Welcome screen in Windows 7 and again the problem carries over to Vista when I tried to log on. Interestingly, Windows 7 gives me an error when I try to use the repair applications to return to a restore point and the application the diagnoses boot problems finds nothing wrong (as the problem isn’t really a boot problem).

In any event, I intend to suspend my testing of Windows 7 until this issue is resolved.

Advertisements

From → Uncategorized

Leave a Comment

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: